Cannot flash despite installing the board, the probe and being on the right port :)

Hello!
We met at Embedded World and I really liked Embeetle.

I am trying it on Ubuntu 22, and struggling with a simple flash on my board.
I did install the board and the probe as per the instruction (it is not a clone). I am flashing on ACM1 as where the board is.
I get this error (install the board)

What do you think is going here :)?

# ----------------------------------------------------------
#        __         **************
#       / /_        * make flash *
#      /_  /        **************
#        /` 
#       ` 
#  Operating system:    
#  Shell:               /bin/sh
#  Shell style:         sh
#  Source folder:       /home/me/arduino_due_blinky
#  Build folder:        /home/me/arduino_due_blinky/build
# ----------------------------------------------------------
stty 1200 raw ignbrk hup < /dev/ttyACM1
"openocd" --info \
                 --port=/dev/ttyACM1 \
                 --force_usb_port=false \
                 --erase \
                 --write \
                 --verify \
                 --boot=1 \
                 --reset \
                 application.bin
Open On-Chip Debugger 0.11.0
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
openocd: unrecognized option '--info'
make: *** [../config/dashboard.mk:192: flash] Error 1
make: Leaving directory '/home/me/arduino_due_blinky/build'
/usr/bin/make: exit code '2'

/home/me/arduino_due_blinky$  

___________________________________________________________________________________
| Flashing failed.                                                                |
| Did you install the board (or flash/debug probe)?                               |
|                                                                                 |
| Check the board installation instructions here:                                 |
|     https://embeetle.com/#supported-hardware/arduino/boards/due                 |
|                                                                                 |
| Check the flash/debug probe installation instructions here:                     |
|     https://embeetle.com/#supported-hardware/arduino/probes/default             |
|_________________________________________________________________________________|
1 Like

Hi @Daja ,
Thank you for reaching out to us.

I see you’re using an Arduino Due board.

Normally the flashtool Bossac should be selected instead of OpenOCD for the board you’re using. You can check that in Dashboard > Tools > Flashtool

Also make sure you installed your Arduino board on Ubuntu:
https://embeetle.com/#supported-hardware/arduino/probes/default

If this didn’t help, we can schedule a video call on Friday. When would be convenient for you? I can make myself available on Friday whole day, except the evening (Belgian timezone).

Kind regards,
Kristof

1 Like

Dear Kristof,

Sorry for the late reply, I could not come back to you yesterday, so I do it first thing in the morning :slight_smile: !

One of the errors was on me. I do not know how the file structure works (yet) and I imported the first blinky file I saw from the embeetle server. But the Uno R3 and the Due have a different chip.

This time I chose the right board. The board is detected on ACM0 and I am in the dialout group.

Now I have an error with avrdude:

# ----------------------------------------------------------
"/usr/bin/avrdude" -C "/usr/etc/avrdude.conf" \
                 -v \
                 -patmega328p \
                 -carduino \
                 -P/dev/ttyS5 \
                 -b115200 \
                 -D \
                 -Uflash:w:application.hex:i

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/usr/etc/avrdude.conf"
avrdude: can't open config file "/usr/etc/avrdude.conf": No such file or directory
avrdude: error reading system wide configuration file "/usr/etc/avrdude.conf"
make: *** [../config/dashboard.mk:172: flash] Error 1
make: Leaving directory '/home/aissata/Desktop/embeetle/embeetle/projects/arduino_uno_r3_blinky/build'
/usr/bin/make: exit code '2'

What do you think it is?

Thank you very much for offering the call, if we don’t make it work we can do that later today :+1:t4:

2 Likes

Hi @Daja ,

The Arduino Uno and Arduino Nano boards use avrdude to flash their chip. The Arduino Due uses bossac. Which board do you have?

I’ll explain below how to use both of these tools.


1. How to use bossac

Make sure you have an Arduino Due board. Open the Arduino Due Blinky project and go into the Dashboard. Go to the Flashtool dropdown menu and select the bossac tool:

image

If the tool is not yet on your computer, Embeetle will download bossac now. Wait for that to complete. Then try to flash again.

Let me know if anything goes wrong. I’m here to help.


 

2. How to use avrdude

Make sure you have an Arduino Nano, Uno or Mega board. These boards all use the avrdude tool to flash their chip. Unfortunately, the following error is very common:

avrdude: can't open config file "/usr/etc/avrdude.conf": No such file or directory

I’ll explain below why you get this error, and how to fix it.

2.1 Background info

PS: You can skip this background info if you just need a quick fix

Here is an interesting link to explain why you get the error that the configuration file avrdude.conf is not found. It’s actually a GitHub issue I filed some months ago:

After filing this GitHub issue, the avrdude authors helped me to fix it in the avrdude source code. I did so, and pushed my fix upstream:

In other words, the problem is solved in avrdude version 7.0!

 

2.2 Quick fix

If you just want a quick fix, I suggest you download the latest version of avrdude (should be at least version 7). We did not yet put this version of avrdude on our public server, but we’ll do that when the next release is ready (probably somewhere next week). Meanwhile, you can download it from our test-server:

https://new.embeetle.com/downloads/beetle_tools/linux/avrdude_7.0.0_64b.7z

Drop the downloaded avrdude_7.0.0_64b.7z somewhere on your computer and unzip it. Then, launch Embeetle. Embeetle always launches the Home Window first. Go into its Toolbox tab:

image

Click on Flash Tool and choose add tool. Select the option Locate on my computer:

image

Finally, point at the avrdude executable:

In my case, the APPLY button is greyed out for reasons that are not relevant to you now. But in your case, it should be possible to click APPLY. From that moment on, Embeetle should know where to find the avrdude tool you just downloaded.

Now open your project again in Embeetle IDE and navigate to the Dashboard. The avrdude version you just downloaded should be in the dropdown list for the Flashtool:

If you cannot see it in the dropdown list, just restart Embeetle and try again.

 

2.3 Final notes

I just like to mention that the next release of Embeetle will provide the latest version of avrdude for direct download from our server. In other words, we are very well aware of the problem and we make sure that our users won’t experience it anymore in the future. However, I hope that the manual fixes explained above can help you in the meantime.


Please let me know if my reply helped you to get your project working.

Kind regards,
Kristof Mulier

1 Like

Hi @Daja ,
Our conversation inspired us to improve the error message for flash fails. Users who still have an old version of avrdude will see the following error message if flashing fails:

Thanks for your feedback. You just made Embeetle IDE better :wink:

Kind regards,
Kristof

2 Likes

Dear Kristof,

Thank you very much for the detailed explanation.

I learned tons and happy to have been able to help you in the process.

I will wait for you to make it available in your servers. I have Linux and the avrdude I have at my disposal is version 6.

Looking forward to keep the avrdude adventure!

1 Like

Hahaha, now I remember again that chapter about the “terrible config file” I wrote long time ago:
https://embeetle.com/#embeetle-ide/manual/flash/flash-tools/avrdude

AVRDUDE is great in many ways, but passing that config file was really terrible. I’m happy it’s solved in v7.0.0. I’ll send you a mail when the next version of Embeetle is online such that you can try it out.

Kind regards,
Kristof

2 Likes

Yeah that’s great documentation, made me smile (and again, learned tons…)

Thank you Kristof.

1 Like