Example STM project

I am trying this IDE for the first time and immediately I have issues. Running on latest update of Windows 10.
If I select the Obsidian or Water theme, most of the line of text in the menu are so dim I canno9t see them unless I move the cursor over them and they get highlighted. Only Air seems to display everything correctly.

I have a Nucleo board, L476RG, and tried to Create a new project, it did its magic downloading a few things and opened up a dashboard with sample code. At least I thought this was an example. It does not compile. The code calls main.h but there is no main.h in the example. I went to the website and tried to follow the steps to create a new project using an example, however the instructions say " Launch Embeetle IDE. Select Download Sample Project in the Home Window, as explained here:" but there is no selection called Download Sample Project. If you mean Create a new project from the list of specified boards, then that did not have a working example.

Hi @mdede439 ,

Please update to Embeetle 1.6.1. We just pushed this new release because there was a problem in fetching projects from the server in version 1.6.0.

As for starting a new project, please press CREATE in the Home Window:


Thanks for pointing out that the documentation isn’t updated yet.

In the next window, you can select project nucleo-l476rg:

Click APPLY when asked to download the tools:


After downloading the tools, the project should open. Wait for the code analysis to complete (see green progressbar in the bottom-right corner):

Finally, press the build button:

Please let me know if it doesn’t build for you.

Hi @mdede439 ,
Thanks for this information, do you perhaps have a retina display monitor? Can you send me a screenshot of the Obsidian or Water text problem that you mentioned?
I see it like this

  • Water:
  • Obisidian:

Thanks and best regards

I just updated to 1.6.1 and the display is the same/ I am using a Dell S2417DG monitor as well as an old Lenovo screen as my second monitor, both running off a Nvidia GTX1050Ti.

Still fails. I assume the build fails because there are a few files that cannot be found that are called in main.c.

Hi @kristof I deleted everything and started again. Downloaded 1.6.0 and then immediately updated to 1.6.1. I do not see the analysis bar you speak of and like I said before there a lot of file missing.

Hi @mdede439 ,
I cannot reproduce the problems you report here on my computer. So I believe the only way to help you is to organize a remote session.

Please install “Chrome Remote Desktop” and send me a mail when you’re available:

Kind regards,

Now, that’s really weird, as if some resource files are missing, because the check-marks are not correctly displayed. They should be images from <path_to_embeetle>\beetle_core\resources, but they seem to be render completely wrong, like the system’s theme or a backup theme. This is how it should look like:

Hi @kristof , I was able to get this working straight away under Linux, GREAT! I then unzipped the 1.6.1 version on a USB key and it worked under Windows 10, GREAT! I then copied the unzipped files from the USB key to a directory on my hard disk, and then it did not work, same errors. I then went through and erased everything that embeetle put on my hard disk and re-unzipped the 1.6.1 version. Now everything works including the themes and example nucleo sketch, GREAT!! I feel something happened when I installed the 1.6.0 version that lingered until I went through and systematically erased everything and started fresh with 1.6.1.

1 Like

Hi @mdede439 ,
Great to see that it works now! Can you confirm that also the Obsidian and Water themes work?

@matkuki : you have any idea why his previous installation didn’t work?


Hi @kristof , yes all the different themes work correctly.

Hi @matkuki , I have no idea what went wrong. When I first installed it, ver 1.6.0, the Create project did nothing. I selected that option and nothing happened. I tried to delete the embeetle directory and try again butt something from Windows would not let me delete everything from that directory. Regardless I re-unzipped the program again on top of the same directory and residual files and Create worked, but I had other issues. Something happened with the first install and caused issues until I completely removed everything and started again fresh with 1.6.1.