IDE not starting in Fedora 33 LXDE

Hi All,

First of all, I really liked your discobot! It was the first time that a forum actually helped me learn how to use one. Thanks for that :+1:

For the problem. Just found out about your amazing IDE and downloaded a copy, extracted it (in home directory for easy testing) and double clicked the embeetle, but nothing happens. Not even a “your dead” message appears (like in the good old games that came to mind while reading your comics)

System is a quite old 2-core cpu desktop with clean (no windows) Fedora 33 LXDE x86-64 lightweight os running on it, but it has been running eclipse for Java (very basic) development for some time now.

Any idea where should I start to look for the causes of the problem?

Hello @joyzpa

Welcome to the forum and thank you for trying Embeetle and the compliments :blush:.

Can you check if there was a ~/.embeetle/ directory created? If it was, please check the contents home_window_output.txt file, that should give some hints of what went wrong. If possible, please post the error message from that file, if there is one. We’ll go from there.


Hi @matkuki

I tried finding that folder before, but failed. Thanks for pointing it for me. Oddly enough the file is quite empty.


Ok, thanks. We’ll install a Fedora 33 LXDE and try it ourselves.
I’ll get back to you as soon as we test it.

Thanks again,

Hey @joyzpa ,

We just reproduced the problem. It seems to be a .so library dependency problem with The output we get by running in the console is:

This application failed to start because no Qt platform plugin could be initialized.  Reinstalling this application may fix this problem.

Now we are trying to fix it. Hang tight.


Hi @matkuki

Thanks for extra fast response time! Promising that you found the problem.


1 Like

Hi @joyzpa,

I have a patch. Here are the installation instructions (command line), assuming that you unpacked Embeetle in ~/embeetle:

cd ~/embeetle/sys/linux/lib
tar xzf embeetle-fedora-patch.tgz

After that, Embeetle should start: either double-click ~/embeetle/beetle_core/embeetle or type


on the command line. If you still have problems, please try the command line and let us know what output you see (if any).

If the fix works, it will be included in the next release of Embeetle.


1 Like

Hi @ygramoel and @matkuki

Just tested the patch and it works great! The IDE starts by double clicking and also from the console with no error messages. Also the home_window_output.txt file stays empty.

I would consider this problem fixed and this topic solved. I’ll get back to you with a new topic linked to this one if I find something odd after I get really using the IDE with some hardware, in some following days.

Thanks again for a fast response and a fix :+1: